Domanda:
MacBook Pro non si connetterà al Wi-Fi, con la password corretta. Errore: "La rete Wi-Fi richiede una password WPA2"
user2895209
2019-03-30 05:11:28 UTC
view on stackexchange narkive permalink

Sto provando a connettermi alla rete Wi-Fi di casa. Quando inserisco la password corretta, viene visualizzato il messaggio "La rete Wi-Fi richiede una password WPA2". Ho verificato che la password sia corretta nella configurazione del mio router.

Utilizzo un MacBook Pro 2017 con macOS Mojave 10.14.2.

Ho riavviato la combinazione modem / router, riavviato il mio MacBook, ho provato a rimuovere il Wi-Fi domestico e ad aggiungerlo di nuovo (in Preferenze di Sistema → Reti → Avanzate → Reti preferite) e ho cambiato la password Wi-Fi. Niente funziona. Anche il mio nome Wi-Fi (SSID) non ha caratteri speciali.

Ho un altro MacBook Pro 2015 e un iPhone che può connettersi al Wi-Fi di casa senza problemi. Quindi, sembra che il problema sembri essere particolare per questo dispositivo (il MacBook Pro 2017) in combinazione con la mia rete domestica. Questo dispositivo non ha problemi di connessione ad altre reti Wi-Fi (Wi-Fi del mio ufficio, Wi-Fi dell'aeroporto, ecc.)

Qualcuno ha mai affrontato questo problema prima? Come lo risolvo?

Aggiornamento 31/5/19: ho provato i due suggerimenti seguenti. Sfortunatamente, ancora senza fortuna. Grazie comunque!

Otto risposte:
#1
+5
William
2019-05-20 06:25:50 UTC
view on stackexchange narkive permalink

Ho appena avuto lo stesso problema.La risposta che ho trovato online diceva di andare alle preferenze di sistema, quindi alla rete, quindi fare clic su Avanzate e quindi su TCP / IP e fare clic su Rinnova DHCP Lease;ma non credo che abbia fatto nulla.

Tuttavia, invece di fare clic su TCP / IP, rimani sulla pagina Wi-Fi (o tornaci facendo clic sulla scheda) e fai clic sul pulsante + per aggiungere la rete.Hai bisogno del nome di rete e della password e per sicurezza ho scelto WPA2 personal.Applica o fai clic su OK e dovrebbe farlo.Per me ha funzionato e ora mi connetto automaticamente.

Uomo!William!Sei un vero salvavita!
#2
+3
Wilfred Smith
2019-03-30 05:46:14 UTC
view on stackexchange narkive permalink

Scommetto che lo stesso SSID ha utilizzato in precedenza un meccanismo di crittografia diverso.

Vai a Preferenze di Sistema -> Reti -> Avanzate e rimuovi l'SSID da "Reti preferite" selezionando e facendo clic su "-";Disattiva "Ricorda reti a cui questo computer si è unito"

Quindi riavvia, vai all'icona Wi-Fi nella barra dei menu (in alto a destra dello schermo), seleziona l'SSID quando viene visualizzato.Inserisci la tua password e, si spera, andrà tutto bene.

Se non funziona, prova a cambiare l'SSID sul tuo modem / router Wi-Fi, assicurandoti che l'SSID sia univoco.Già che ci sei, esegui l'upgrade alla 10.14.4 poiché sono stati risolti alcuni problemi Wi-Fi apparentemente non correlati.

Per favore condividi qual è il tuo SSID.Scommetto che la tua macchina ha "ricordato" un'altra rete Wi-Fi con lo stesso SSID, ma metodo di crittografia diverso.

Ehi, la modifica dell'SSID (nome di rete) ha risolto il problema per me.Per ulteriori informazioni se aiuta gli altri, avevo sia una rete 2.4G che 5G e il problema della password si verificava solo sulla rete 5G.Ho rimosso la rete 2.4G e ho rimosso una e commerciale che avevo nel mio SSID precedente.Penso che fosse necessario solo cambiare l'SSID, ma ho pensato di condividere anche tutto lo sfondo.
Modifica: Uffa, lo riprendo.Ha smesso di funzionare di nuovo 20 minuti dopo con lo stesso problema.
#3
+3
El Guapo
2019-10-14 00:32:11 UTC
view on stackexchange narkive permalink

Non so se hai risolto il tuo problema, ma è così che il mio problema è stato risolto.

Ho un router BT Homehub, quindi le impostazioni (nella scheda "avanzate") mi hanno permesso di "separare" le impostazioni dei canali a 2,4 GHz e 5 GHz che hanno reso visibili 2 SSID sulla rete.Il canale a 5 GHz era riconoscibile per l'aggiunta di "-5" al mio SSID originale.Mi sono connesso al canale 5GHz senza alcun problema.

Sembra che il mio problema fosse l'incapacità del mio MacBook air di connettersi al canale a 2,4 GHz.

Spero che funzioni anche per te!

Ho spento il mio canale a 2,4 GHz e finalmente sono riuscito a ricollegare il mio MacBook Air alla rete.La mia rete TP-Link Deco non mi consente di separare i canali, quindi spero che rimanga connesso ora che ho riattivato i 2,4 GHz.Grazie per il consiglio
#4
+1
Steve Radcliffe
2020-05-14 01:27:24 UTC
view on stackexchange narkive permalink

Ho improvvisamente riscontrato questo problema con l'hardware che è andato bene per un paio d'anni.Andava bene dopo il recente aggiornamento del software, quindi concludo che si tratta di un problema hardware.

#5
  0
hamayun zeb
2020-01-16 11:29:35 UTC
view on stackexchange narkive permalink

Apri Activity Monitor

Cerca SystemUIServer nella scheda CPU

Fare clic su "Nell'angolo superiore con il pulsante con la croce".Forza l'uscita

enter image description here (X) "

#6
  0
user3779917
2020-04-20 10:25:15 UTC
view on stackexchange narkive permalink

Ho trovato la soluzione dopo che non sono riuscito a trovare nulla online e nemmeno il personale di supporto senior di Apple lo sapeva.Basta eseguire i seguenti due ripristini:

Reimposta NVRAM o PRAM su Mac

Come reimpostare l'SMC del tuo Mac

#7
  0
IsraelM17
2020-07-29 21:58:33 UTC
view on stackexchange narkive permalink

Ho avuto lo stesso problema come te e ho trovato una soluzione.Nel mio caso ho collegato un hub USB 3.0 al mio Mac mini 2018, quindi macOS aggiunge questo hub come altre impostazioni di rete.

Se scolleghi il tuo hub o un altro dispositivo che macOS rileva come una porta di rete, il WiFi funziona bene, ma per rimanere connesso con l'hub o qualche dispositivo, vai su Preferenze di Sistema / Rete e imposta inattivi i dispositivi che mostrano questa finestra(USB, Hub, Thunderbolt, ecc.) E con questo ora il mio WiFi funziona bene.

#8
  0
Kirill Bessonov
2020-09-01 00:58:37 UTC
view on stackexchange narkive permalink

Ho avuto esattamente lo stesso problema con il mio nuovissimo router Asus RT-AX58U che supportava la modalità WiFi 6 e non ero in grado di connettermi alla mia rete sulla banda da 2,4 Ghz sul mio MacBook Air con High Sierra 10.13.1.Tutti i miei dispositivi Windows e Android non hanno avuto problemi con la connettività.Avevo provato a cambiare WPA2 in modalità WPA2 / WPA e da AES a TKIP , ho dimenticato la rete nelle impostazioni Wi-Fi del Mac, ma non mi è stato d'aiuto.Poi per caso avevo trovato un post simile su WMM e la chiave era impostare Enable WMM No-A recognition su Disable e tutto iniziò a funzionare come un incantesimo.Questa opzione si è rivelata essenziale per un'associazione di rete 2.4Ghz di successo sui router Asus Mac.Il mio consiglio è di giocare con le impostazioni WMM (Wifi Multimedia) del tuo router, quindi vedi se aiuta. enter image description here



Questa domanda e risposta è stata tradotta automaticamente dalla lingua inglese. Il contenuto originale è disponibile su stackexchange, che ringraziamo per la licenza cc by-sa 4.0 con cui è distribuito.
Loading...